置顶

小涛

搬砖 2022-05-21 来自 小米11

#四神 Four Gods 攻略#

游戏攻略,游戏成本, 游戏价格等

#搬砖##助手##四神#

0
0
240

置顶

小涛

搬砖 2022-05-21 来自 小米11

0
0
14

置顶

小涛

搬砖 2022-05-09 来自 小米11

#A3幸存者 A3:STILL ALIVE 攻略#

190级到200级攻略, 200级后游戏成本, 游戏价格等

#搬砖##a3##a3幸存者##助手#

0
0
38

置顶

小涛

开发 2022-03-22 来自 小米11

#CentOS SK#

[该文章已加密,请点击标题输入密码访问]

#centos##代理##socks5#

0
0
0

置顶

小涛

开发 2022-03-22 来自 小米11

#CentOS HTTP#

[该文章已加密,请点击标题输入密码访问]

#centos##http##代理#

0
0
0

小涛

搬砖 2022-05-18 来自 小米11

#解封谷歌话术#

[该文章已加密,请点击标题输入密码访问]

#谷歌#

0
0
0

小涛

搬砖 2022-05-11 来自 小米11

#windows 显卡设置#

通过预览调整图像设置

  • 使用我的优先选择,侧重于 - 性能

管理3D设置

  • 图形增强(图像锐化) - 开
  • OpenGL 渲染GPU - 独立显卡
  • 平滑处理 灰度纠正 - 关
  • 电源管理模式 - 最高性能优先
  • 纹理过滤质量 - 高性能
  • 线程优化 - 开

设置好后重启电脑就行啦

#显卡#

通过预览调整图像设置

  • 使用我的优先选择,侧重于 - 性能

管理3D设置

  • 图形增强(图像锐化) - 开
  • OpenGL 渲染GPU - 独立显卡
  • 平滑处理 灰度纠正 - 关
  • 电源管理模式 - 最高性能优先
  • 纹理过滤质量 - 高性能
  • 线程优化 - 开

设置好后重启电脑就行啦

#显卡#

展开
0
0
1

小涛

2022-05-09 来自 小米11

#易语音 截取局域图片#

.版本 2
.支持库 BmpOperate

.子程序 小涛_截取图片, 字节集, , 精易 图片_取图片区域 升级版
.参数 原图, 字节集
.参数 x1, 整数型, , 左边
.参数 y1, 整数型, , 顶边
.参数 x2, 整数型, , 右边
.参数 y2, 整数型, , 顶边
.局部变量 对象, 对象
.局部变量 位图, 位图, , "2"
.局部变量 新宽度, 整数型
.局部变量 新
.版本 2
.支持库 BmpOperate

.子程序 小涛_截取图片, 字节集, , 精易 图片_取图片区域 升级版
.参数 原图, 字节集
.参数 x1, 整数型, , 左边
.参数 y1, 整数型, , 顶边
.参数 x2, 整数型, , 右边
.参数 y2, 整数型, , 顶边
.局部变量 对象, 对象
.局部变量 位图, 位图, , "2"
.局部变量 新宽度, 整数型
.局部变量 新高度, 整数型
.局部变量 点阵大小, 整数型
.局部变量 点阵字节集, 字节集
.局部变量 后图, 字节集

新宽度 = x2 - x1 + 1
新高度 = y2 - y1 + 1
位图 [1].载入数据 (原图)
.如果真 (位图 [1].取位深度 () ≠ 24)
    对象.创建图片对象 (原图)
    位图 [1].载入数据 (对象.取回图片 ())
.如果真结束
位图 [2].创建 (新宽度, 新高度, 24, )
位图 [1].复制到 (x1, y1, 新宽度, 新高度, 位图 [2], 0, 0, )
后图 = 位图 [2].取位图数据 ()
点阵大小 = (新宽度 × 3 + (4 - 新宽度 × 3 % 4) % 4) × 新高度
点阵字节集 = 到字节集 (点阵大小)
后图 = 字节集替换 (后图, 35, 取字节集长度 (点阵字节集), 点阵字节集)
返回 (后图)

#易语言##图片##e##字节集#

展开
0
0
2

小涛

mysql 2022-05-07 来自 小米11

#mysql 取两个表某字段不重复数据#

SELECT * FROM `库A` WHERE NOT EXISTS ( SELECT * FROM `库B` where `库A`.字段 = `库B`.字段 );

#mysql##字段##不重复#

0
0
3

小涛

mysql 2022-05-07 来自 小米11

#mysql 取字段左边 右边#

取出目标字段的左边

UPDATE `库` SET 字段=SUBSTRING_INDEX(目标字段, ' ', 1);

取出目标字段的右边

UPDATE `库` SET 字段=SUBSTRING_INDEX(目标字段, ' ', -1);

#mysql##字段#

取出目标字段的左边

UPDATE `库` SET 字段=SUBSTRING_INDEX(目标字段, ' ', 1);

取出目标字段的右边

UPDATE `库` SET 字段=SUBSTRING_INDEX(目标字段, ' ', -1);

#mysql##字段#

展开
0
0
3

小涛

2022-05-04 来自 小米11

#易语音 图片多点比色#

.版本 2

.子程序 小涛_多点比色, 逻辑型
.参数 主图, 字节集
.参数 代码, 文本型, , 格式 0|6|77C0EB,0|0|77C0EB
.局部变量 颜色数组, 文本型, , "0"
.局部变量 i, 整数型
.局部变量 临时_X, 整数型
.局部变量 临时_Y, 整数型
.局部变量 临时_RGB, 字节集
.局部变量 临时_主图, 字节集
.局部变量 找到次数, 整数型

找到
.版本 2

.子程序 小涛_多点比色, 逻辑型
.参数 主图, 字节集
.参数 代码, 文本型, , 格式 0|6|77C0EB,0|0|77C0EB
.局部变量 颜色数组, 文本型, , "0"
.局部变量 i, 整数型
.局部变量 临时_X, 整数型
.局部变量 临时_Y, 整数型
.局部变量 临时_RGB, 字节集
.局部变量 临时_主图, 字节集
.局部变量 找到次数, 整数型

找到次数 = 0
临时_主图 = 图片_到24位图 (主图)

颜色数组 = 分割文本 (代码, “,”, )
' 调试输出 (取数组成员数 (颜色数组))
.计次循环首 (取数组成员数 (颜色数组), i)
    临时_X = 到整数 (文本_取左边 (颜色数组 [i], “|”))
    临时_Y = 到整数 (文本_取出中间文本 (颜色数组 [i], “|”, “|”))
    临时_RGB = 字节集_十六进制到字节集 (文本_取右边 (颜色数组 [i], “|”))
    .如果真 (取字节集长度 (临时_RGB) = 3)
        .如果真 (图片_取像素RGB (临时_主图, 临时_X, 临时_Y, 临时_RGB [1], 临时_RGB [2], 临时_RGB [3]))
            找到次数 = 找到次数 + 1
        .如果真结束

    .如果真结束

.计次循环尾 ()
.判断开始 (找到次数 ≥ 到数值 (取数组成员数 (颜色数组) × 0.9))
    返回 (真)
.默认
    返回 (假)

#易语言##图片##e##字节集#

展开
0
0
2

小涛

开发 2022-04-23 来自 小米11

#常用的正则表达式#

网络IP

/^\d+\.\d+\.\d+\.\d+$/

域名

/^(?:[A-za-z0-9-]+\.)+[A-za-z]{2,4}(?:[\/\?#][\/=\?%\-&~`@[\]\':+!\.#\w]*)?$/

手机号 宽松

/^0?1[3|4|5|6|7|8][0-9]\d{8}$/

手机号 严谨

/^(?:(?:\+|00)86)?1(?:(?:3[\d])|(?:4[5-79])|(?

网络IP

/^\d+\.\d+\.\d+\.\d+$/

域名

/^(?:[A-za-z0-9-]+\.)+[A-za-z]{2,4}(?:[\/\?#][\/=\?%\-&~`@[\]\':+!\.#\w]*)?$/

手机号 宽松

/^0?1[3|4|5|6|7|8][0-9]\d{8}$/

手机号 严谨

/^(?:(?:\+|00)86)?1(?:(?:3[\d])|(?:4[5-79])|(?:5[0-35-9])|(?:6[5-7])|(?:7[0-8])|(?:8[\d])|(?:9[189]))\d{8}$/

QQ

/^([0-9]{5,11})$/

QQ邮箱

/^([0-9]{5,11})@qq.com$/

邮箱

/^(([^<>()[\]\\.,;:\s@"]+(\.[^<>()[\]\\.,;:\s@"]+)*)|(".+"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$/

网址

/^[a-zA-z]+:\/\/[^\s]*$/
/^(((ht|f)tps?):\/\/)?[\w-]+(\.[\w-]+)+([\w.,@?^=%&:/~+#-]*[\w@?^=%&/~+#-])?$/

微信号, 6至20位,以字母开头,字母,数字,减号,下划线

/^[a-zA-Z][-_a-zA-Z0-9]{5,19}$/

密码强度校验,最少6位,包括至少1个大写字母,1个小写字母,1个数字,1个特殊字符

/^\S*(?=\S{6,})(?=\S*\d)(?=\S*[A-Z])(?=\S*[a-z])(?=\S*[!@#$%^&*? ])\S*$/

mac地址

/^((([a-f0-9]{2}:){5})|(([a-f0-9]{2}-){5}))[a-f0-9]{2}$/i

用户名

/^[a-zA-Z0-9_-]{4,16}$/

火车车次

/^[GCDZTSPKXLY1-9]\d{1,4}$/

IMEI

/^\d{15,17}$/

磁力链接 宽松

/^magnet:\?xt=urn:btih:[0-9a-fA-F]{40,}.*$/

md5

/^([a-f\d]{32}|[A-F\d]{32})$/

base64格式

/^\s*data:(?:[a-z]+\/[a-z0-9-+.]+(?:;[a-z-]+=[a-z0-9-]+)?)?(?:;base64)?,([a-z0-9!$&',()*+;=\-._~:@/?%\s]*?)\s*$/i

银行卡号

/^[1-9]\d{9,29}$/

车牌号 新能源

/^[京津沪渝冀豫云辽黑湘皖鲁新苏浙赣鄂桂甘晋蒙陕吉闽贵粤青藏川宁琼使领][A-HJ-NP-Z](?:((\d{5}[A-HJK])|([A-HJK][A-HJ-NP-Z0-9][0-9]{4}))|[A-HJ-NP-Z0-9]{4}[A-HJ-NP-Z0-9挂学警港澳])$/

车牌号 非新能源

/^[京津沪渝冀豫云辽黑湘皖鲁新苏浙赣鄂桂甘晋蒙陕吉闽贵粤青藏川宁琼使领][A-HJ-NP-Z][A-HJ-NP-Z0-9]{4}[A-HJ-NP-Z0-9挂学警港澳]$/

车牌号 新能源 + 非新能源

/^[京津沪渝冀豫云辽黑湘皖鲁新苏浙赣鄂桂甘晋蒙陕吉闽贵粤青藏川宁琼使领][A-HJ-NP-Z][A-HJ-NP-Z0-9]{4,5}[A-HJ-NP-Z0-9挂学警港澳]$/

#正则##正则表达式#

展开
0
0
2
1 2