.版本 2
.支持库 BmpOperate

.子程序 小涛_截取图片, 字节集, , 精易 图片_取图片区域 升级版
.参数 原图, 字节集
.参数 x1, 整数型, , 左边
.参数 y1, 整数型, , 顶边
.参数 x2, 整数型, , 右边
.参数 y2, 整数型, , 顶边
.局部变量 对象, 对象
.局部变量 位图, 位图, , "2"
.局部变量 新宽度, 整数型
.局部变量 新高度, 整数型
.局部变量 点阵大小, 整数型
.局部变量 点阵字节集, 字节集
.局部变量 后图, 字节集

新宽度 = x2 - x1 + 1
新高度 = y2 - y1 + 1
位图 [1].载入数据 (原图)
.如果真 (位图 [1].取位深度 () ≠ 24)
    对象.创建图片对象 (原图)
    位图 [1].载入数据 (对象.取回图片 ())
.如果真结束
位图 [2].创建 (新宽度, 新高度, 24, )
位图 [1].复制到 (x1, y1, 新宽度, 新高度, 位图 [2], 0, 0, )
后图 = 位图 [2].取位图数据 ()
点阵大小 = (新宽度 × 3 + (4 - 新宽度 × 3 % 4) % 4) × 新高度
点阵字节集 = 到字节集 (点阵大小)
后图 = 字节集替换 (后图, 35, 取字节集长度 (点阵字节集), 点阵字节集)
返回 (后图)