.版本 2

.子程序 小涛_多点比色, 逻辑型
.参数 主图, 字节集
.参数 代码, 文本型, , 格式 0|6|77C0EB,0|0|77C0EB
.局部变量 颜色数组, 文本型, , "0"
.局部变量 i, 整数型
.局部变量 临时_X, 整数型
.局部变量 临时_Y, 整数型
.局部变量 临时_RGB, 字节集
.局部变量 临时_主图, 字节集
.局部变量 找到次数, 整数型

找到次数 = 0
临时_主图 = 图片_到24位图 (主图)

颜色数组 = 分割文本 (代码, “,”, )
' 调试输出 (取数组成员数 (颜色数组))
.计次循环首 (取数组成员数 (颜色数组), i)
    临时_X = 到整数 (文本_取左边 (颜色数组 [i], “|”))
    临时_Y = 到整数 (文本_取出中间文本 (颜色数组 [i], “|”, “|”))
    临时_RGB = 字节集_十六进制到字节集 (文本_取右边 (颜色数组 [i], “|”))
    .如果真 (取字节集长度 (临时_RGB) = 3)
        .如果真 (图片_取像素RGB (临时_主图, 临时_X, 临时_Y, 临时_RGB [1], 临时_RGB [2], 临时_RGB [3]))
            找到次数 = 找到次数 + 1
        .如果真结束

    .如果真结束

.计次循环尾 ()
.判断开始 (找到次数 ≥ 到数值 (取数组成员数 (颜色数组) × 0.9))
    返回 (真)
.默认
    返回 (假)